Hlavní navigace

Názor ke zprávičce Canonical pracuje na podpoře zstd pro dpkg a apt od SlávekB - XZ je možné v balíčích používat už od...

  • 12. 3. 2018 18:05

    SlávekB (neregistrovaný) ---.axis.cz

    XZ je možné v balíčích používat už od Debianu 6.x (Squeeze) a to jak pro zdrojové, tak pro binární balíčky. Ohledně Ubuntu platí, že XZ je možné používat už od Ubuntu 10.04 (Lucid) pro zdrojové a od Ubuntu 10.10 (Maverick) i pro binární. V Debianu 8.x (Jessie) tedy komprese XZ nepřišla, ale jen byla nastavena jako výchozí. A díky tomu, že podpora XZ byla připravená už několik let předem, tak byl přechod hladký.

    Zatím to nevypadá, že by podpora ZStandard byla doplněna do oficiálního dpkg. A pokud nebude doplněna dříve, než s touto kompresí začne Ubuntu publikovat balíčky, tak tím způsobí nekompatibilitu. Tak jako tak způsobí nekompatibilitu se stávajícími verzemi Debian i Ubuntu distribucí.