Hlavní navigace

Dvanáct let stará chyba v Polkit umožňuje získat práva roota

Sdílet

Petr Krčmář 26. 1. 2022
Hacker útok Autor: Depositphotos

Dvanáct let stará chyba byla objevena v systémovém nástroji Polkit. Chyba nazvaná PwnKit umožňuje neprivilegovanému útočníkovi získat práva roota a jen pár hodin po zveřejnění informací o chybě se objevily první skutečné útoky.

Problém se konkrétně nachází v binárce pkexec, která je součástí všech běžných distribucí včetně těch nejpoužívanějších jako Ubuntu, Debian, Fedora či CentOS. Chyba přitom existuje už dvanáct let, od samého začátku existence této utility. Dostala označení CVE-2021–4034.

Utilita pkexec, podobně jako známější sudo, umožňuje autorizovanému uživateli provádět akce pod jiným uživatelským účtem. Pokud není výslovně řečeno jinak, spustí se proces pod uživatelem root. Chyba samotná spočívá ve špatném ošetření obsahu proměnných prostředí, který je za správných okolností spuštěn jako kód. Útočník tak může vytvořením vlastních proměnných donutit utilitu provést libovolnou akci pod rootem. Chyba není zneužitelná vzdáleně, přesto je velmi závažná a měli byste co nejdříve aktualizovat.

Našli jste v článku chybu?
  • Aktualita je stará, nové názory již nelze přidávat.