Hlavní navigace

Názor ke zprávičce PHP 5.3.29 je poslední v řadě 5.3 od D.J.Bobo - No, znepokojující spíš je, že PHP 5.4 má...

  • Aktualita je stará, nové názory již nelze přidávat.
  • 20. 8. 2014 9:27

    D.J.Bobo (neregistrovaný) ---.solidvision.cz

    No, znepokojující spíš je, že PHP 5.4 má některé funkce (bohužel hojně využívané) buď Deprecated (to by ještě šlo) nebo doknce už je vypustila a nahradila novými (a to je problém u větších projektů typu SigarCRM atd.

    Řešil jsem teď vtigerCRM na PHP 5.4 a byl to děs ... hromada věcí nefungovala. A vzhledem ke komunitní verzi je update často hodně zpožděn (samozřejmě že pokud to prodávám jako službu, pak si to upravíim ...).

    Takže mi nezbylo, než analyzovat chybný kód a upravovat ... a patchovat ... a patchovat.

    PS: Bylo by hezké, kdyby PHP mělo možnost "nalinkovat" z důvodu zpětné kompatibility i starší (vypuštěné) funkce (asi to navrhnu vývojářům).