Hlavní navigace

WordPress 4.9.3 má rozbité automatické aktualizace, novou verzi musíte nainstalovat ručně

Petr Krčmář

Vývojáři populárního redakčního systému WordPress upozorňují na nepříjemnou chybu, která se dostala do vydání 4.9.3. Kvůli ní neprojde automatická aktualizace a pokud se správce o situaci nepostará, nebude instalace WordPressu dostávat žádné další bezpečnostní záplaty. Vývojáři vydali opravnou verzi 4.9.4, která opravuje jen tuto chybu v souborech wp-includes/update.php a wp-includes/version.php. Aktualizovat ji ale musíte ručně.

Existuje několik různých cest, jak ruční aktualizaci udělat: nejjednodušší je v administraci kliknout na Updates → Update Now. Můžete také použít řádkové rozhraní WP-CLI, přepsat přímo zmíněné PHP soubory na disku nebo zavolat správnou funkci na serveru například příkazem:

$ php -r 'include "wp-load.php"; wp_maybe_auto_update();'
Našli jste v článku chybu?