Hlavní navigace

Běh linuxového jádra se zkomplikuje na starších ARM procesorech

Sdílet

Adam Štrauch 11. 4. 2013

Na linux-arm-kernel mailing listu oznámil Russell King odstranění podpory pro NWFPE (NetWinder Floating Point Emulator) a VFP (Vector Floating Point) emulaci výpočtů s čísly s desetinou čárkou. To ovlivní hlavně ARM procesory, které nedisponují podporou pro hardwarové zpracování takových čísel, což jsou starší ARM procesory ARMv4 a ARMv5. Důvodem odstranění je nekompatibilita těchto implementací s licencí GPLv2, pod kterou je jádro uvolňováno.

Našli jste v článku chybu?
  • Aktualita je stará, nové názory již nelze přidávat.
  • 11. 4. 2013 17:15

    j (neregistrovaný) 2001:470:9e70:----:----:----:----:----

    Nejak nechapu ... kdyby bylo neco odmitnuto pri zarazeni, tak OK, ale vyhazovat neco, co uz tam je ??? WTF ???

  • 11. 4. 2013 18:49

    jano (neregistrovaný) ---.dynamic.chello.sk

    no to čo je zaradené treba udržovať a to chce ľudí ktorý môžu robiť niečo užitočnejšie ako udržiavať vec čo používa pár desiatok ľudí..

  • 11. 4. 2013 20:18

    janiczek (neregistrovaný) 78.128.142.---

    vždyť tam je napsané, že to vyhodili kvůli licenci, ne kvůli nedostatku lidí, kteří to používají...

  • 11. 4. 2013 22:58

    bez přezdívky

    Zajímavý je pak asi i důvod, proč to začalo vadit tak najednou:

    This I have done after it has been brought to my attention by the OSADL's GPL-violations project that the license for the softfloat library is incompatible with GPLv2. This is because the FSF have ruled that indemnification clauses consitute an "additional restriction" which is incompatible with the GPLv2 section 6. NWFPE contains the softfloat library, and VFP's emulation code is a derivative of softfloat.

    Tj. licence knihovny softfloat není ve shodě s GPLv2 v tom, že obsahuje klauzuli o "odškodnění", na které autor trvá, a na to Russel přišel až teď.