Hlavní navigace

Bzip2 1.0.6 opravuje bezpečnostní chybu

Sdílet

Petr Krčmář 22. 9. 2010

V kompresním nástroji bzip2 byla objevena vážná bezpečnostní chyba, která umožňuje vytvoření speciálního komprimovaného souboru. Při jeho rozbalování pak dojde k přetečení zásobníku a za určitých okolností může být bez interakce s uživatelem spuštěn kód obsažený v archivu. Vývojáři tedy po více než dvou letech vydali novou opravnou verzi 1.0.6, která díru záplatuje.

Našli jste v článku chybu?
  • Aktualita je stará, nové názory již nelze přidávat.