Hlavní navigace

Debian chce v příští verzi (Buster) odstranit Qt4

Petr Krčmář

Vývojáři Debianu plánují odstranění zastaralé knihovny Qt4 z příští verze 10 s kódovým jménem Buster. Stále ještě existuje proprietární software využívající tuto verzi knihovny, ale vývojáři doufají, že se jim co nejdříve podaří přechod na Qt5. Lisandro Damián Nicanor Pérez Meyer, vývojář Debianu, psal o následujících plánech v mailing listu. Odstranění hodně používané knihovny je vždy těžké, ale Qt4 je už dlouho mrtvé a už jsme ho museli začít upravovat pomocí netestovaných patchů.

Vývojáři budou do udržování Qt4 vkládat co nejméně úsilí a prý jej raději úplně odstraní než aby prováděli nějaké komplikované změny pro udržení kompatibility. To znamená, že se věci rozbijí. Pokud tedy závisíte na nějakém otevřeném software vyžadujícím Qt4, začněte s portací. Pokud používáte proprietární software, měli byste výrobci říct, že je čas aktualizovat. Opravdu.

(Zdroj: Phoronix)

Našli jste v článku chybu?