Hlavní navigace

Debian unstable končí s podporou TLS 1.0 a 1.1

Petr Krčmář

Do vývojové verze Debianu (unstable/Sid) byla nahrána nová verze balíčku OpenSSL, která už neobsahuje podporu pro zastaralé šifrovací protokoly TLS 1.0 a 1.1. Jediným podporovaným tedy zůstává aktuální TLS 1.2. To může v budoucnu způsobit nekompatibilitu se staršími systémy, které z nějakého důvodu novou verzi TLS nepodporují. Je proto důrazně doporučováno začít s aktualizací.

Nový balíček s OpenSSL se v běžném vydání Debianu objeví přibližně za dva roky, tedy s vydáním verze 10 Buster. TLS 1.2 je v OpenSSL už pět let a podporu je možné nalézt asi na 90 % veřejných serverů. Přesto je nutné upozornit na to, že pokud z nějakého důvodu používáte unstable na serveru, může se hodně věcí rozbít.

Našli jste v článku chybu?