Hlavní navigace

Firefox starší než 87 nebo 78.9 ESR může mít problém s DRM videem

Sdílet

Jan Fikar 4. 6. 2021
Firefox loga

Google 31. května 2021 aktualizoval klíče v modulu Widevine pro dešifrování obsahu (CDM). Widevine používá Firefox pro přehrávání videa s DRM.  Uživatelé Firefoxu mající starší verze než 87 nebo 78.9 ESR mohou narazit na problémy s přehráváním videí ze streamovacích služeb, jako jsou Amazon Prime, Netflix, Hulu, Disney+ a jiné.

Řešením je aktualizace Firefoxu, což by se mělo automaticky nabídnout i při pokusu o přehrání videa s DRM.

(zdroj: mozilla.cz)

Našli jste v článku chybu?
  • Aktualita je stará, nové názory již nelze přidávat.
  • 4. 6. 2021 19:47

    Mintaka

    Řešením není aktualizace například na Windows XP, kde je poslední podporovaná verze 52 ESR. HW ty počítače stále mají na to, aby přehrály např. video z YouTube, ale některé technikálie kolem jim hází klacky pod nohy.

    Uvidíme jak na to zareaguje K-Meleon.

    Za případné konstruktivní tipy jak řešit FF na starých PC (CPU 1GHz, 1GB RAM) s Win XP budu rád.

    PS: Rád bych se zde vyhnul flame na téma, proč mít na PC Win XP.

  • 5. 6. 2021 11:50

    Ladis

    Tak Mozilla podporuje starší OS mnohem více než velké konkurenční prohlížeče, takže jí bych určitě nevyčítal, že nemyslí na 20 let starý Windows XP (sám ho mám jako třetí OS v tripplebootu kvůli starým hrám). Tady je smutný, že i když Windows používá 87 % lidí, tak se nenajde nikdo, kdo by dělal podporu u opensource software pro staré verze OS (jako je TenFourFox - Firefox udržovaný pro MacOS X 10.4 a 10.5 a CPU PowerPC). Nicméně zrovna u chráněného obsahu (Amazon Prime, Netflix, Hulu, Disney+) to asi není problém, protože kdo si neupgraduje hardware, tak nebude platit měsíční subscription a spíš využije stažení obsahu nelegálně.

    PS: Když chceš konstruktivní tipy, tak jeden z hlavních důvodů, proč se používá Firefox na starých Windows, je řešení SSL ručně a ne přes API OS. Díky tomu fungují i stránky šifrované protokoly, které už staré verze Windows neumí. Pokud chceš používat např. prohlížeče založené na Chrome nebo IE, tak je vícero způsobu, jak vyřešit nepodporovanou verzi SSL/TLS:
    https://superuser.com/questions/1487553/proxy-or-other-solution-that-can-allow-vintage-browsers-before-https-era-wi

  • 5. 6. 2021 11:58

    Mintaka

    Díky za tip.

    Ty XPčka v mém okolí jsou převážně za Linuxovým serverem, takže po vzoru té HTTPS proxy bych mohl zkusit oživit technologii, kterou jsem používal v dobách vytáčeného spojení a sice Squid proxy.

    https://wiki.alpinelinux.org/wiki/Setting_up_Explicit_Squid_Proxy

  • 6. 6. 2021 11:28

    okalousek (neregistrovaný) 2a02:768:af1c:----:----:----:----:----

    Tak proč ne? Viděl jsem jak to používají jako telnet terminál.