Hlavní navigace

GnuPG „classic“ 1.4.19

3. 3. 2015

Sdílet

Bezpečnostní nástroj GnuPG, resp. verze GnuPG „classic“ (1.4), jež se primárně využívá na starších embedded platformách, se dočkal nového vydání – 1.4.19.

Řeší především možné útoky pomocí postranních kanálů (CVE-2014–3591 a CVE-2015–0837). Dále přibyla volba „keep-ownertrust“, byl upraven buildovací systém atd. Bližší podrobnosti si můžete přečíst v oznámení o vydání.

GnuPG je šířeno pod GNU GPL a je svobodnou alternativou ke komerčnímu systému PGP, se kterým je ale na úrovní OpenPGP standardu kompatibilní. Poskytuje nástroje pro šifrování a digitální podepisování za pomocí asymetrické a symetrické kryptografie. Je vhodný pro zabezpečení e-mailové komunikace, hojně je využíván také k digitálnímu podepisování balíčků v linuxových distribucích apod.

Našli jste v článku chybu?
  • Aktualita je stará, nové názory již nelze přidávat.

Byl pro vás článek přínosný?

Autor zprávičky

Michal Strnad pracuje ve sdružení CESNET, provozující národní síť vědy a výzkumu, Akademii věd České republiky a jako redaktor na serveru Root.cz. Kromě počítačů rád běhá, kuchtí a čte vše, co se mu dostane pod ruku.