Hlavní navigace

Intel záplatuje bezpečnostní díry v GPU od Ivy Bridge (2012) po Coffee Lake (2017)

Sdílet

David Ježek
Procesor rozbitý Intel

Do Linuxu míří patch na chybu CVE-2019–14615 týkající se možnosti získání dat z GPU Intel Gen9 (Gen8 se chyba netýká) při lokálním přístupu útočníka. Oprava spočívá v tom, že je mazán stav všech výpočetních jednotek GPU (Intel je značí EU – execution unit) při každém přepnutí obsahu. Dle Debianu se chyba logicky týká jader od 3.16.x po 5.4.x, bude tedy řešena u všech v současné době podporovaných jader, včetně nejstarších trojkových s prodlouženou podporou.

Později se ukázalo, že oprava je nutná i pro starší generace GPU sahající až po první 22nm procesory Ivy Bridge, včetně generace Haswell.

Našli jste v článku chybu?
Ochrana proti spamovacím robotům. Odpovězte prosím na následující otázku: Jaký je letos rok?