Hlavní navigace

KDE možná zruší podporu pro staré grafické karty

Sdílet

Petr Krčmář 22. 2. 2012

Martin Gräßlin, vedoucí vývojář projektu KWin, zvažuje na svém blogu zrušení podpory grafických karet, které umí jen OpenGL 1.x. Argumentuje tím, že všechny novější grafické karty a čipy zvládají OpenGL 2.0. Konkrétně karty ATI od roku 2002, Nvidia od roku 2004 a Intel počínaje rokem 2006. Udržování podpory starších karet je podle něj neefektivní, zvyšuje složitost kódu a komplikuje jeho správu.

Martin chce s rozhodnutím počkat na příchod Mesa 3D 8.0 a ovladače llvmpipe, který dovolí všechny grafické efekty vytvářet softwarově. Tím by vzniklo řešení pro uživatele starších grafických karet. „Pokud budu s výkonem spokojený, odstraním kód OpenGL 1.x,“ uzavírá ve svém blogpostu.

(Zdroj: The H)

Našli jste v článku chybu?
  • Aktualita je stará, nové názory již nelze přidávat.
  • 23. 2. 2012 14:16

    Vin (neregistrovaný) ---.kolej.mff.cuni.cz

    Šlo by o upuštění od podpory compositingu v kwinu, ne o podporu KWinu samotného. Jen pro upřesnění, ve zprávičce to není explicitně.