Hlavní navigace

Linux 5.15 už nezkompilujete s GCC 4.9 a starším

Sdílet

David Ježek 15. 9. 2021
Tux Linux Autor: Larry Ewing

Jedna z posledních změn v rámci vývoje příští verze jádra Linux 5.15 povyšuje minimální verzi GCC pro kompilaci. Až dosud stačilo GCC 4.9, nyní bude pro sestavení jádra potřeba minimálně GCC 5.1. Jde současně o verzi, která je už delší dobu potřebná pro build na architektuře Aarch64 (64bit ARM).

Lze předpokládat, že změna nebude mít zásadní dopad na linuxové systémy, neb používaná verze GCC je typicky o hodně vyšší. Aktuální je GCC 11.2 z července tohoto roku. GCC 5.1 přišlo na svět v dubnu 2015, verze 4.9 pak v dubnu 2014. Zahození kódu souvisejícího s GCC 4.x představuje úsporu zanedbatelných cca 350 řádků kódu. A jak připomíná Phoronix, tehdy v roce 2014 se Linus Torvalds o GCC 4.9 vyjádřil velmi, velmi nelichotivě.

Našli jste v článku chybu?