Hlavní navigace

Linuxové jádro 3.18 padá, problém se možná týká i 3.17

Petr Krčmář

Když před týdnem vyšlo testovací jádro verze 3.18-rc6, Linus Torvalds v oznámení upozornil, že obsahuje neznámý problém, kvůli kterému jádro padá na kernel panic. Uběhl týden, ale vývojáři se stále snaží přijít na to, co se vlastně stalo. Navíc to ještě vypadá, že se problém týká i jader řady 3.17.

Podle článku na Phoronixu je sice analýza poměrně komplikovaná, v mailing listu se už ale objevilo několik podezření: problém se může týkat Xenu nebo kódu watchdogu. Dokonce to podle některých vývojářů vypadá, že jde o více různých problémů, které se projevují podobně.

Vydání jádra 3.18 se tak pravděpodobně zdrží, dokud nebude viník objeven a opraven. Dobrou zprávou je, že se během „hloubkových vrtů“ v kódu objevilo několik dalších problémů, které vyžadují pozornost vývojářů. Výsledkem tak snad nakonec bude stabilnější a lepší kód.

Našli jste v článku chybu?