Hlavní navigace

Minimální softwarové požadavky pro Firefox v Linuxu

Petr Krčmář

Aby byl balíček s Firefoxem univerzální, používají vývojáři starší verze knihoven. Potíž ovšem je, že použití těchto verzí s sebou nese řadu problémů, obcházení starých chyb a podobně. Výsledkem je tak komplikovaný vývoj. Nyní podle Mikea Connora nastal čas posunout se dále a zahodit podporu starých verzí. Tak, jako už nebude Firefox 3 podporovat MS Windows 9×, nebude zřejmě brát ohled ani na starší linuxové distribuce.

K dispozici je už i nový návrh minimálních verzí podporovaných knihoven. Jsou mezi nimi například GTK+ 2.10.x, GLib 2.12.x a GNOME 2.16.x. Ty jsou dnes již obsaženy ve všech moderních desktopových distribucích. Otázkou ovšem zůstává, jaké potíže přinese změna uživatelům enterprise distribucí s dlouhou podporou starších knihoven.

(Zdroj: JasnáPáka)

Našli jste v článku chybu?