Hlavní navigace

Opožděně, ale přece vyšel Linux 4.15

Sdílet

Jan Fikar 29. 1. 2018

Včera Linus Torvalds vydal kernel 4.15 s názvem Fearless Coyote, který se kvůli chybám Spectre a Meltdown opozdil o dva týdny. I tak některé věci zbývá ještě dořešit (ARM, Spectre v1). Retpoline záplata pro Spectre v2 vyžaduje podporu GCC, pokud takové GCC ještě nemáte, cat /sys/devices/system/cpu/vulnerabilities/spectre_v2 ukáže Vulnerable: Minimal generic ASM retpoline. To znamená, že jen kód jádra v assembleru je zatím ošetřený Retpoline.

Zbytek oprav je „nudný“ a Linus by si přál nudný také kernel 4.16, protože jak říká: „Because boring really is good“.

(zdroj: phoronix)

Našli jste v článku chybu?
  • Aktualita je stará, nové názory již nelze přidávat.
  • 29. 1. 2018 9:46

    Peter Fodrek

    A co Spectre V1-ka, pomoze mi update z 4.14.15?

    #cat /sys/devices/sys­tem/cpu/vulne­rabilities/mel­tdown
    Not affected

    #cat /sys/devices/sys­tem/cpu/vulne­rabilities/spec­tre_v1
    Vulnerable

    # cat /sys/devices/sys­tem/cpu/vulne­rabilities/spec­tre_v2
    Mitigation: Full AMD retpoline

    #uname -a
    Linux ... suse 4.14.15-4.g12e5c10-default #1 SMP PREEMPT Fri Jan 26 08:52:08 UTC 2018 (12e5c10) x86_64 x86_64 x86_64 GNU/Linux

  • 29. 1. 2018 10:57

    8B3CE273 (neregistrovaný) ---.office.ignum.cz

    Nepomůže

    Linux 4.14.15-1-ARCH #1 SMP PREEMPT Tue Jan 23 21:49:25 UTC 2018 x86_64 GNU/Linux

    cat /sys/devices/sys­tem/cpu/vulne­rabilities/mel­tdown
    Mitigation: PTI

    cat /sys/devices/sys­tem/cpu/vulne­rabilities/spec­tre_v1
    Vulnerable

    cat /sys/devices/sys­tem/cpu/vulne­rabilities/spec­tre_v2
    Mitigation: Full generic retpoline

  • 29. 1. 2018 11:02

    alfa (neregistrovaný) ---.amigonet.cz

    díky chybám -> kvůli chybám