Hlavní navigace

Debian Squeeze nebude mít Chromium

Sdílet

Adam Štrauch 13. 9. 2010

Chromium se proti jiným prohlížečům velmi rychle vyvíjí a uživatelé ani nestačí sledovat, jak se jim mění pod rukama. Naneštěstí to má i své nevýhody, protože vývojový tým Debianu rozhodl, že se Chromium 5 do podporovaných repositářů nedostane a šestka je ještě málo otestovaná. Důvodem jsou rychlé a rozsáhlé změny, které v kódu vývojáři dělají a bylo by obtížné backportovat bezpečnostní opravy z šestky do pětky. Samozřejmě tu zůstanou neoficiální repositáře, které budou Chromium obsahovat, takže kdo bude chtít, ten si ho najde.

Našli jste v článku chybu?
  • Aktualita je stará, nové názory již nelze přidávat.
  • 14. 9. 2010 11:06

    Nomen (neregistrovaný) 193.245.34.---

    Beztak je pro takovéhle aplikace lepší backports repo nebo 3rd party repo.
    Stabilní a konzervativní jádro systému (core, ne kernel ;-)) doplněné o (důvěryhodné) 3rd party repositáře s jednotlivými aplikacemi, u kterých je žádoucí jejich aktuálnost. Chromium, Firefox, OpenOffice.org, Gimp, VLC, mplayer, VirtualBox,… Podle toho co kdo potřebuje. To je asi optimální desktop.

  • 14. 9. 2010 12:20

    Jiří J. (neregistrovaný) 188.175.39.---

    Docela bych uvítal nějaký seznam „důvěryhodných“ repozitářů těch nejběžnějších aplikací, vím jen o „debian backports“ (vesměs jen díky nedávné zprávičce), pak o volatile, kde je podstatný vesměs jen clamav, … a to je asi vše.

  • 14. 9. 2010 15:04

    Nomen (neregistrovaný) 193.245.34.---

    A to je právě ten problém. Ideální by bylo, kdyby repositáře spravoval přímo upstream (viz např. http://www.virtualbox.org/wiki/Linux_Downloads nebo http://go-oo.mirrorbrain.org/stable/linux-x86_64/).

    Vždyť přece nemusí podporovat všechny distribuce. Stačí ty s dlouhým vývojovým cyklem: Debian stable a CentOS(/RHEL). Možná ještě Ubuntu LTS, kde velmi pomůže Launchpad. Jak se SLED, přiznám se, nevím. Zabývat se distribucemi s krátkým vývojovým cyklem (Fedora, Ubuntu, Mandriva,…) nebo s rolling-updates je zbytečné – těch se tahle varianta netýká.

    A že to umí i „proprietární“ upstream dokazuje YUM repositář Adobe obsahující flash-plugin a reader (bohužel stále jenom i386, x86–64 v nedohlednu). Případně repositáře Googlu.