Hlavní navigace

Linux 4.19 vyžaduje vyšší verzi GCC

Sdílet

David Ježek
GCC logo

Až dosud stačilo ke zkompilování linuxového jádra (pre)historické GCC 3.2 z roku 2002. Nadcházející jádro 4.19 ale tuto minimální verzi zvýší na GCC 4.6 (z roku 2011), viz příslušný patch, který včera Linus Torvalds začlenil. Jádro tak bude explicitně kontrolovat, zdali je kompilováno s touto, nebo vyšší verzí a případně „hodí“ chybovou hlášku. Z jádra tak bude moci zmizet pár věcí, které jen ošetřovaly chyby a specifika ve starších verzích GCC. Prozatím je nadále GCC jedinou cestou ke kompilaci jádra, na poli LLVM/Clang ještě není hotovo.

Našli jste v článku chybu?
Ochrana proti spamovacím robotům. Odpovězte prosím na následující otázku: Jaký je letos rok?